The minimum system requirements for Norton Internet Security are:

Operating System Operating Systems Supported
Windows
  • Microsoft Windows XP (all 32-bit versions) with Service Pack 3 (SP 3) or later
  • Microsoft Windows Vista (all versions) with Service Pack 1 (SP 1) or later
  • Microsoft Windows 7 (all versions) with Service Pack 1 (SP 1) or later
  • Microsoft Windows 8/8.1 (all versions). Some protection features are not available in Windows 8 Start screen browsers.
  • Microsoft Windows 10 (all versions). Edge browser not supported.
Mac
  • Current and previous two versions of Mac OS X. Password Management feature not supported.
  • Norton Family and Norton Family Premier features not supported
Android
  • Android 4.0.3 or later. Must have Google Play app installed.
  • Android 4 or later required for Norton Family Premier Android app
iOS
  • iOS 8 or later
Was this answer helpful ? Yes (0) / No (0)

Leave a Reply

Your email address will not be published. Required fields are marked *